Helm Chart v2.0

Back to the Changelog

The v2.0 release of the FlowFuse Helm Chart includes a breaking change for deployments making use of the forge.localPostgresql setting when upgrading. This is where the helm chart installs a dedicated PostgreSQL database instance.

With v2.0 we have updated the version of the Bitnami PostgreSQL Helm sub-chart we bundle and the upgrade process will require some manual intervention to ensure things work correctly. A fresh install should not require any extra steps.

The steps are documented on the Upgrade instructions page, please read them carefully before upgrading

Also included in this release is the ability to set resource constraints and Pod Security Context on the FlowFuse application, File-Server Application and MQTT broker containers if required. Details of how to set those can be found in the Helm Chart README.md

Comments:

Written By:

Senior Software Developer

Published on:

Recent Updates:

Sign up for updates